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About This Guide
What This Guide Contains
The Lotus Domino Journaling Configuration Guide provides information about:

• How Domino journaling works

• Setting up Domino Server to send copies of email messages to your archive 
in Message Archiving.

The information in this guide is intended for: 

• Administrators of the Message Archiving service

• Administrators of Domino Server

This guide is a supplement to the Message Archiving Administration Guide. It 
assumes that you are familiar with the message security service. For details about 
using the features and components of that service, refer the Message Security 
Service Administration Guide. These documents are available on the Postini 
Support Portal. For details, see “How to Get Support” on page 8.

This guide describes how Message Archiving works with Lotus Domino Server 
and the configurations that Google recommends. Please consult IBM’s Web site 
for the latest configuration and support information for Domino Server and related 
products.
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Related Documentation
For additional information about Message Archiving and your Message Security 
service, refer to the following related documents, which are available on the 
Postini Support Portal. For details, see “How to Get Support” on page 8.

How to Get Support
Your Message Security service provides several options for getting support for 
Message Archiving, including:

• Administrator documentation and FAQs

• A searchable knowledge base

• Support tools

• Email support

• Phone support

• Instructor-led and self-paced training

• Account management

To access support resources, go to the Postini Support Portal at:

Document Description

Message Archiving 
Administration Guide

Instructions for setting up Message Archiving 
on your Message Security service; granting 
Message Archiving setup, search, and audit 
privileges to other users; and creating usage 
reports on Message Archiving storage.

Message Archiving User’s 
Guide

Instructions for searching for, viewing, 
managing, and exporting archived email 
messages, IM conversations, and IM file 
transfers. Also includes instructions for 
creating archive audit reports, which show the 
activities that archive users performed in the 
archive.

Message Security Service 
Administration Guide

Instructions for setting up and administering 
your Message Security service, including how 
to set up your organization hierarchy, create 
user accounts, grant privileges to users, 
provide Message Center access to users, 
configure junk email and virus filters, and 
create reports.
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https://support.postini.com

Note: Postini Customer Care does not provide technical support for configuring 
mail servers or third-party products. Please contact Postini Professional Services 
Services (professionalservices@postini.com) for consulting services.

How to Send Comments About This Guide
We value your feedback. If you have comments about this guide, please send an 
email message to: 

postini-doc_comments@google.com

In your email message, please specify the section to which your comment applies. 
If you want to receive a response to your comments, ensure that you include your 
name and contact information.
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Chapter 1
Introduction to Lotus Domino Journaling Chapter 1
What Is Domino Server Journaling?
Domino Server journaling lets you record copies of email communications in your 
organization and store, or journal, them in a Mail Journaling database. The 
process of journaling is different from archiving. Journaling is simply a means of 
retaining copies of your users’ messages. Archiving, on the other hand, is a 
means of storing, managing and applying policies to those copies in a separate 
environment for the purposes of discovery, regulatory compliance, data retention, 
or server maintenance.

You can journal all messages, or you can create rules to journal only specific 
messages.

Once you configure journaling on Domino Server, messages are forwarded from 
the Mail Journaling database to Message Archiving.

What Are the System Requirements for Domino Server Journaling?
Ensure that your Domino messaging environment includes the following 
components.

Supported Domino Servers

Lotus Domino Server 6.5.4 - 8.5

Required Domino Software for Administrators

• IBM Lotus Notes 6.5.4 - 8.5

• IBM Domino Administrator 6.5.4 - 8.5

• IBM Domino Designer 6.5.4 - 8.5
Introduction to Lotus Domino Journaling 11



How Does Domino Server Journaling Work?
Before you enable journaling, you create a Mail Journaling database, which uses 
a Postini database template. The Postini template contains the code that 
implements the Postini Journaling Agent. The Mail Journaling database can be 
local to a server, or you can create a remote database used by one or more 
servers.

When journaling is enabled, email that passes through the MAIL.BOX database 
on a Domino server is examined to see which messages meet the criteria for 
journaling. Messages that meet those criteria are copied to a Domino Mail 
Journaling database.

The Postini Journaling Agent periodically forwards journaled messages from the 
Mail Journaling database to your Postini Archive, and then deletes those 
messages from the Mail Journaling database.

Domino Journaling Message Flow

The following figure shows the flow of messages through your Domino Server and 
out to your Postini archive:
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What Should I Do Before Setting Up Journaling?
Before you set up journaling on your Domino Server, we recommend that you first 
do the following:

• Ensure that you have Configuration Settings documents for the servers

• Outline the server mail rules you want to implement for journaling

• Adjust quotas on the mail databases

• Create an additional email account for each user who can search the Postini 
archive

• Set up TLS (Transport Layer Security)

Configuration Settings Documents

A Configuration Settings document governs mail routing for a Domino server. You 
can use a single document to govern all your Domino servers, different 
documents to govern different groups of servers, or a separate document for each 
server. The server mail rules you use to define journaling are configured within the 
Configuration Settings document for each server on which you want to journal 
messages. We recommend using a single Configuration Settings document. You 
can create that document ahead of time, or during the process of configuring you 
Domino server for journaling.

Server Mail Rules

You create rules that determine which messages are journaled. You can create a 
rule that causes all messages to be journaled, or you can create more granular 
rules to journal only certain types of messages, like messages from specific 
employees to specific customers. Make some determination about the types of 
messages you want to journal before you begin configuring your mail rules.

Adjust Mail Database Quotas

Journaling email messages consumes additional Domino Server resources. You 
can mitigate some of that impact by setting quotas on individual mail file 
databases. As mail files grow, access to those files consumes more processor, 
memory, disk I/O, and network-bandwidth resources. Setting quotas on those files 
can help reduce their demands on server resources.

When you provide Domino users with access to the Personal Archive, messages 
are stored in and are available from the Personal Archive, eliminating a lot of the 
need to store messages on your Domino servers. You can then safely set smaller 
quotas for mail file databases.

For detailed information about setting mail quotas, refer to the developerWorks 
area of the IBM Web Site:
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For more information about the Personal Archive, refer to the Message Archiving 
Administration Guide.

Create Email Accounts for Users with the Archive Search 
Privilege

A user who has permission to search your corporate archive can export archived 
messages by sending them to the Domino email address registered with your 
Postini Message Security service. If Domino journals messages for that user, 
each exported message is archived, resulting in two archived copies of the 
message: the original copy in the archive and a copy of the exported message.

If you want to avoid re-archiving messages that users export as attachments:

1. Create an additional, separate email account on your Domino Server for each 
user who can search your corporate archive.

2. After enabling journaling, create the necessary mail rules to exclude those 
accounts from the journaling process. (For details, see http://www.ibm.com/
developerworks/lotus/library/ls-D6ServerMailRules.)

Ensure that you add these new email accounts to your Message Security service, 
and place them in an organization for which you have turned on archiving. Then 
grant the Archive Search permission to each account’s authorization record.

For information about setting up organization hierarchies, refer to the Message 
Security Service Administration Guide.

For instructions about granting Message Archiving privileges, refer to the 
Message Archiving Administration Guide.

Note: If users with the Archive Search privilege will export message from the 
archive by downloading them to a file only—instead of sending them as 
attachments to their email addresses—you need not set up separate accounts for 
them. Messages that users download to a file are not re-archived.

Using the TLS Protocol

Message Archiving supports TLS (Transport Layer Security) encryption, providing 
you with an option to enhance the security of your outbound journaled email 
messages. The TLS protocol over SMTP is a certificate-based authentication 
method that provides security-enhanced data transfers by using symmetric 
encryption keys. Using TLS, however, is not required.

If you set up your Domino Server to use TLS encryption, Message Archiving will 
automatically accept the encrypted messages as they are forwarded by your 
Domino Server, decrypt them, and then store them in your archive. 
14 Message Archiving - Domino Journaling Configuration Guide
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You can find detailed information about setting up TLS (SSL) for Domino Server 
on the IBM Web site (www.ibm.com).
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Chapter 2
Setting Up Lotus Domino Journaling Chapter 2
Overview of Journaling Setup
The following are the basic steps for setting up Domino Server journaling:

1. Install the Postini templates for the Mail Journaling database and the optional 
Postini Log database.

2. Create the Mail Journaling Database, which will contain your journaled email 
messages and forward them to your archive.

3. Configure access control for the new Mail Journaling database. To complete 
this step, you can use the settings that we recommend.

4. Set properties for the Mail Journal database so that it can work with your 
archive.

5. Create a mail-in database document to identify the Mail Journal database in 
Domino Directory.

6. Configure Domino Server for journaling. Specify where the Domino Mail 
Router will send journaled messages, and create the rules that Domino Mail 
Router will use when processing journaled messages.

7. Optional: Create the Postini Log database to keep a log of the Postini 
Journaling Agent’s activities.

8. Configure the Postini Journaling Agent with the address of your archive.

9. Activate journaling by restarting the Domino Mail Router.
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Legal Disclaimer

This guide describes how Postini products work with Lotus Domino Server and 
the configurations that Postini recommends. These instructions are designed to 
work with the most common Lotus Domino Server scenarios. Any changes to 
Lotus Domino Server configuration should be made at the discretion of your Lotus 
Domino Server administrator.

How to Set Up Journaling on Domino Server
Before completing the following steps to set up journaling and send messages to 
your archive, ensure that you have completed the following:

• Turn on archiving for your Message Security service user organizations.

• Configure journaling for your Message Security service email configuration 
organization. Once you complete this configuration, your Message Security 
service displays the email address for your archive. The format for your 
archive email address is:

archive@your_ID.archive.psmtp.com

This is the address to which the Domino server will forward journaled 
messages.

For details, refer to the Message Archiving Administration Guide.

• Plan your journaling deployment. For details, see “What Should I Do Before 
Setting Up Journaling?” on page 13.

Step 1. Install the Postini Templates

Postini provides two database templates that allow the Domino server to work 
with Postini Message Archiving:

• Postini Mail Journaling template (postinimailjrn.ntf): Based on the 
standard Domino mail-journal template. Use this template to create the Mail 
Journaling database. This template contains the Postini Journaling Agent, 
which runs on your Domino server to forward journaled messages to your 
archive.

• Postini Log template (postinilog.ntf): Based on the standard Domino log 
template. Use this template to create the optional Postini Log database, which 
logs the activities of the Postini Journaling Agent.
18 Message Archiving - Domino Journaling Configuration Guide
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The templates are available from the following links:

• 6.5.4 Mail Journaling template

• 6.5.4 Log template

• 7.0 Mail Journaling template

• 7.0 Log template

• 7.0.2 Mail Journaling template

• 7.0.2 Log template

• 7.0.3 Mail Journaling template

• 7.0.3 Log template

• 8.0.2 Mail Journaling template

• 8.0.2 Log template

• 8.5 Mail Journaling template

• 8.5 Log template

To install the Postini templates:

Copy the templates to the Domino Directory on the Domino server where you will 
create the Mail Journaling database and the Postini Log database.

Step 2: Create the Mail Journaling Database

After you install the Postini templates, you are ready to create the Mail Journaling 
database. Your Domino Mail Router will send a copy of each journaled email 
message to this database. You need to create the database on the server to 
which you are sending your journaled email.

To create the Mail Journaling database:

1. Open the Lotus Notes client.

2. Click File > Database > New.
Setting Up Lotus Domino Journaling 19
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The New Database dialog box appears.

3. Under Specify New Database Name and Location:

• In the Server field, select the server on which you want to create the 
database.

• In the Title field, enter the following title (name) for the database: Domino 
Mail Journal.

• In the File name field, enter the following file name: mailjrn.nsf.

By default, the file is created in the local Data directory.

To create the file in another local directory, add the drive letter and path to 
the file name, for example: C:\Databases\mailjrn.nsf.

4. Under Specify Template for New Database:

• In the Server field, select the server on which the template resides.

• Select the check box for Show advanced templates.

• From the Template list, select Postini Mail Journaling (6n) or Postini 
Mail Journaling (7n), depending on your version of Domino (6.5.4 - 
7.0.3).

5. Click OK.
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Step 3: Configure Access Control for the Mail Journaling 
Database

The Access Control List (ACL) for a database controls which users can perform 
which tasks in the database, and which servers can replicate which data in the 
database.

To configure the ACL for the Domino Mail Journal Database:

1. Open the Lotus Notes client.

2. Open the Domino Mail Journal database:

• Click File > Database > Open.

• From the Server list, select the server on which you created the database.

• In the Filename field, enter mailjrn.nsf.
• Click Open.

3. Click File > Database > Access Control.

4. Set the user and server access as follows (click Add to add users if 
necessary):

User/Server Role, Access, and Privileges

Default Role: None

Access: No Access

Privileges:

Create documents: No

Delete documents: No

Create private agents: No

Create personal folders/views: No

Create shared folders/views: No

Create Lotus Script/Java agents: No

Read public documents: No

Write public documents: No

Replicate or copy documents: No
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Anonymous Role: None

Access: No Access

Privileges:

Create documents: No

Delete documents: No

Create private agents: No

Create personal folders/views: No

Create shared folders/views: No

Create Lotus Script/Java agents: No

Read public documents: No

Write public documents: No

Replicate or copy documents: No

LocalDomain-
Administrators

Role: Admin

Access: Manager

Privileges:

Create documents: Yes

Delete documents: Yes

Create private agents: Yes

Create personal folders/views: Yes

Create shared folders/views: Yes

Create Lotus Script/Java agents: Yes

Read public documents: Yes

Write public documents: Yes

Replicate or copy documents: Yes

User/Server Role, Access, and Privileges
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LocalDomain-Servers Role: Admin

Access: Manager

Privileges:

Create documents: Yes

Delete documents: Yes

Create private agents: Yes

Create personal folders/views: Yes

Create shared folders/views: Yes

Create Lotus Script/Java agents: Yes

Read public documents: Yes

Write public documents: Yes

Replicate or copy documents: Yes

OtherDomain-Servers Role: None

Access: No Access

Privileges:

Create documents: No

Delete documents: No

Create private agents: No

Create personal folders/views: No

Create shared folders/views: No

Create Lotus Script/Java agents: No

Read public documents: No

Write public documents: No

Replicate or copy documents: No

User/Server Role, Access, and Privileges
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5. Click OK.

Step 4: Set Properties for the Mail Journaling Database

To set the database properties:

1. Open the Lotus Notes client.

2. Click File > Database > Open to open the database.

Administration Server Role: Admin

Access: Manager

Privileges:

Create documents: Yes

Delete documents: Yes

Create private agents: Yes

Create personal folders/views: Yes

Create shared folders/views: Yes

Create Lotus Script/Java agents: Yes

Read public documents: Yes

Write public documents: Yes

Replicate or copy documents: Yes

User/Server Role, Access, and Privileges
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3. Click File > Database > Properties to open the Database properties dialog 
box.

4. Set the following properties:

Tab Settings

Basics Type: Standard

Disable background agents for this 
database: Clear check box

Allow use of stored forms in this database: 
Select check box

Design Include in multi-database indexing: Clear 
check box

Inherit design from master template: Select 
check box

• Template Name: <the template you 
selected when you created the database>

Allow design locking: Clear check box
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5. Close the Database properties dialog box.

Step 5: Create the Mail-in Database Document

After you create and configure the Mail Journaling database (Domino Mail 
Journal), you then have to create the corresponding Mail-In Database document 
so that the database can receive mail.

To create the Mail-In Database document:

1. Open the Lotus Notes client.

2. Open the Domino Directory:

• Click File > Database > Open.

• From the Server list, select the server on which you created the Mail 
Journaling database.

• From the Database list, select the directory for that server.

For example, if you selected Server01.com, then select Server01.com’s 
Directory.

• In the Filename field, select or enter names.nsf.
• Click Open.

3. Open the Mail-In Databases view:

• In the navigation pane, expand Configuration.

• Expand Messaging.

• Under Messaging, select Mail-In Databases and Resources.

4. Click Add Mail-In Database.

Launch When opened in Notes client: Open 
designated Frameset

Name: MailFS

Restore as last viewed by user: Select check 
box

Full Text Clear check boxes for all options.

Advanced Don’t maintain unread marks: Select check 
box

Allow soft deletions: Clear check box

Tab Settings
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5. Set the following properties for the new Mail-In Database:

6. Click Save and Close.

Step 6: Configure the Domino Server for Journaling

Journaling is enabled from the Configuration Settings document. If you already 
have the necessary Configuration Settings document, the following procedures 
explain how to modify the document to enable journaling. If you do not already 
have the necessary Configuration Settings document, the instructions for creating 
one are included in the following procedures.

To configure the Domino server for journaling:

1. Open the Lotus Notes client.

2. Open the Domino Directory:

• Click File > Database > Open.

• From the Server list, select the server on which you created the Mail 
Journaling database.

• From the Database list, select the directory for that server.

For example, if you selected Server01.com, then select Server01.com’s 
Directory.

• In the Filename field, select or enter names.nsf.
• Click Open.

Tab Settings

Basics Mail-In Name: ..DominoMailJournal (use the .. 
prefix to separate this database name from 
others)

Description: Domino Mail Journal

Internet Access: Leave this field blank

Internet Message Storage: Select Prefer MIME

Encrypt incoming mail: No

Domain: Your Domino domain

Server: The full name of the server (for 
example, Domino1/Postini) on which the Mail 
Journaling database resides

File name: The file name of the Mail Journaling 
database (mailjrn.nsf)

Administration Allow foreign directory synchronization: No
Setting Up Lotus Domino Journaling 27



3. Open the Server Configurations view:

• In the navigation pane, expand Configuration.

• Expand Servers.

• Under Servers, select Configurations.

4. Create or open for edit the All Servers Configuration Settings document.

• If the document does not exist:

Click Add Configuration.

On the Basics tab, select the check box for Use these settings as the 
default settings for all servers.

Save the Configuration Settings document.

• If the document does exist, select the document, then click Edit 
Configuration.

5. Open the Journaling tab of the Configuration Settings document:

• Click the Router/SMTP tab.

• Click the Advanced tab.

• Click the Journaling tab.

6. Set the values for the following options:

7. Save the Configuration Settings document.

8. Open the Rules tab of the Configuration Settings document:

• Click the Router/SMTP tab.

• Click the Restrictions and Controls tab.

• Click the Rules tab.

9. Click New Rule.

The New Rule dialog box appears.

Option Value

Journaling Enabled

Field encryption 
exclusion list

• Form

• From

• Principal

• Posted Date

Method Send to Mail-In database

Mail destination Domino Mail Journal

(the title of the Mail Journaling database)
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10. Create the condition to journal all email messages:

• In the This rule is field, select On.

• From the first drop-down list, select all documents, then click Add.

11. Create an exception to the condition so that messages sent to your Postini 
Archive email address are not journaled again:

• In the Create field, select Exception.

• From the first drop-down list, select To.

• From the second drop-down list, select is.

• In the next field (Value to check), enter your Postini Archive email address 
(archive@your_ID.archive.psmtp.com).

• Click Add.

12. If you created special email accounts for users who can search the archive 
(“Create Email Accounts for Users with the Archive Search Privilege” on 
page 14), you need to create another condition/exception pair for each 
address.

In this case, repeat Steps 10 and 11. 

When repeating Step 11, in the Value to check field, enter the appropriate 
email address.

13. In the Specify Actions section, select Journal this message.

14. Click Add Action.

15. Click OK.

16. Open the Outbound tab of the Configuration Settings document:

• Click the MIME tab.

• Click the Conversion Options tab.

• Click the Outbound tab.

17. Set the following two options to Enabled (enabling the first option displays the 
second option):

• Lookup Internet address for all Notes addresses when Internet address is 
not defined in document

• Perform exhaustive lookups when converting Notes addresses to Internet 
addresses

18. Click Save and Close.

19. Close the Domino Directory.

Step 7: (Optional) Create Postini Log Database

If you want to log the activity of the Postini Journaling Agent, you need to create 
the Postini Log database.
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To crate the Postini Log database:

1. Open the Lotus Notes client.

2. Click File > Database > New.

The New Database dialog box appears.

3. Under Specify New Database Name and Location:

• In the Server field, select the server on which you created the Mail 
Journaling database (Domino Mail Journal).

• In the Title field, enter the following title (name) for the database: Postini 
Archiving Log.

• In the File name field, enter the following file name: postiniLog.nsf.

By default, the file is created in the local Data directory.

To create the file in another local directory, add the drive letter and path to 
the file name, for example: C:\Databases\mailjrn.nsf.

4. Under Specify Template for New Database:

• In the Server field, select the server on which you created the Mail 
Journaling database (Domino Mail Journal)

• Select the check box for Show advanced templates.

• From the Template list, select Postini Archive Log (6n) or Postini 
Archive Log (7n), depending on your version of Domino (6.5.4 - 7.0.3).

5. Click OK.

Step 8: Configure the Postini Journaling Agent

Configuration of the agent involves:

• Setting properties in the profile document

• Setting properties of the agent

• Adding the agent server to the Mail Journaling database ACL

• Setting the heap size for the JVM

Setting Profile Document Properties

To set the agent properties in the profile document:

1. Open the Mail Journaling database (Domino Mail Journal).

2. From the Actions menu, select Modify Postini Properties.
30 Message Archiving - Domino Journaling Configuration Guide



3. Set the following properties:

4. Click Save.

Setting Agent Properties

To set the agent properties:

1. Open the Mail Journaling database (Domino Mail Journal).

2. Click View > Agents.

3. Double-click postiniArchive.

The agent properties dialog box opens.

4. Click the Basics tab, and in the Rutime section, click Schedule.

5. In the Where The Agent Runs section, use the Run on list to select the server 
on which the agent resides.

6. Click the Security tab.

7. In the Run on behalf of field, enter the name of the server on which the agent 
resides.

8. Under Set runtime security level, select 3. Allow restriced operations with 
full administration rights.

9. Close the properties dialog box.

Adding the Agent Server to the Mail Journaling Database ACL

To add the agent server to the Mail Journaling database ACL:

1. Open the Mail Journaling database (Domino Mail Journal).

2. Click File > Database > Access Control.

Property Value

Archive Email 
Address

Your Postini Archive email address 
(archive@your_ID.archive.psmtp.com)

Archive Log DB postiniLog.nsf

Logging Level Select one of the following:

• 0 (disabled)

• 1 (Warning)

• 2 (Debug)
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3. Click Basics, then click Add.

4. Enter the server on which the agent resides.

5. Click OK.

6. From the People, Server, Groups list, select the server name.

7. From the User type list, select Server.

8. From the Access list, select the access level you want to assign to the server.

9. Click OK.

Setting the Heap Size for the JVM

The Postini Journaling Agent is a java program, and so relies on the java heap 
size settings in notes.ini. If the journaled messages exceed the heap size, then 
when the Postini Journaling Agent tries to process the load, the agent fails. To 
avoid failure on the part of the agent, Postini recommends the following setting for 
the heap size:

JavaMaxHeapSize=256mb

JavaMinHeapSize=128mb

If the agent fails at any point because the heap size was exceeded, you can 
adjust these settings as necessary.

Step 9: Activate Journaling

Your next step is to restart the router on the Domino server in order to activate 
journaling.

To restart the router:

1. Start the Domino Administrator:

For example, on a Windows computer, click Start > Programs > Lotus 
Applications > Lotus Domino Administrator.

2. Click the Server tab, then click the Status tab.

3. Select the Server Tasks view.

4. In the list of tasks, right-click Router, then click Restart Task.

5. Click Yes.
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Verify Domino Server Journaling Setup
After you finish setting up Domino Server journaling, you can verify that messages 
are being journaled and archived as expected.

Verify Journaling

1. Using your Notes client, send a message to yourself or any user who falls 
within the scope of your journaling configuration. In the CC field of the 
message, add the address of a mailing list. In the BCC field, add the address 
of one recipient.

2. Examine the Mail Journaling database (Domino Mail Journal) to verify that a 
copy of the message is there. Retrieve the message and verify that all of the 
intended recipients are listed.

Verify Archiving

1. To verify that Message Archiving is archiving journaled email messages from 
your Domino server, send a test email message to a user. Ensure that the 
user’s account on your Message Security service resides in an organization 
for which you turned on archiving. 

2. After about 60 minutes, use Message Archiving to search for the message by 
the recipient’s email address, the message’s subject, or both. For details, 
refer to the Message Archiving User’s Guide.

Note: The time it takes for a message to enter the archive can vary. If the 
message does not appear in the archive, try searching for it again after 
another 60 minutes.
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Troubleshoot Domino Server Journaling Setup
If you cannot verify that Message Archiving is archiving journaled messages, do 
the following:

Verify that you configured the Postini Journaling Agent with the correct Archive 
Email Address.

If you entered this address incorrectly, the agent cannot send the journaled 
messages to your archive.

Refer to the instructions for setting the agent properties in “Setting Profile 
Document Properties” on page 30.
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Chapter 3
Monitoring Journaling Performance Chapter 3
Once you have successfully deployed Domino Server journaling, there are three 
easy ways to monitor journaling activity and spot potential problems:

• Use the Storage Overview report in Message Archiving

• Use the Inbound Archiving by Domain report in the Administration Console

• Turn on journaling alerts
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Use the Storage Overview report in Message Archiving
Message Archiving administrators who have the Archive Search and Archive 
Reports privileges can view the Storage Overview report, which includes an up-to-
the-minute view of your journaling traffic.

To view the Storage Overview report, log in to Message Archiving, click the 
Reports tab, then click Storage Overview in the Navigation panel.

The Mail Flow (last hour) panel graphs the following data for journaled 
messages for the last hour:

• Green/Archived: Number of messages successfully archived.

• Blue/Non-Account: Number of messages not archived because there is no 
corresponding account in the system. These messages are dropped unless 
Non-account archiving is enabled for an org.

• Red/Non-Journaled: Number of messages sent to the archive in an invalid 
format. This is often due to non-envelope journaling. A virtual recipient 
(nonenvelopejournal@archive.psmtp.com) is added to the messages’ meta 
data. You can search the archive for these messages by searching for 
messages that have the recipient nonenvelopejournal.

• Magenta/Bounced: Number of messages bounced. This is often due to not 
having entered your journaling server’s IP-address range correctly when you 
created the Journaling Configuration.

• Blank: Indicates there is no journal traffic.
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Use the Inbound Archiving by Domain report in the Administration 
Console

You can use the Inbound Archiving by Domain report in the Message Security 
Administration Console to get a summary of the following data related to 
journaling:

• Account Messages: Messages journaled for active archiving users.

• Non-Account Messages: Valid journals for users who do not have archiving 
enabled. These journals are archived if Non-account Archiving is enabled.

• Invalid Messages: Journals that are not in the correct format. These can 
include status messages sent to the journaling inbox and forwarded to the 
archive, so a very small number of these does not necessarily indicate a 
problem. If a large percentage of journal traffic is listed as Invalid, then check 
your journal configuration.

To view the Inbound Archiving by Domain report:

1. Log in to your Administration Console.

2. Select the appropriate email config.

3. Click the Reports tab.

4. Click Inbound > Archiving > Domain.

Turn on journaling alerts
You can edit the journaling configuration for an email config to turn on journaling 
alerts. For information about the options available in a journaling configuration 
and how to edit one, see the Message Archiving Administration Guide.

When you turn on Alert Status for a journaling configuration, you then receive 
alerts that cover the following conditions:

• Journaled messages from your server are being bounced

Note: This condition occurs when the IP address of the server from which you 
are sending journaled messages is not listed in the Administration Console. If 
the system bounces three messages within a minute without receiving any 
good messages, this alert is issued.

• Journaled messages from your server are not in the correct envelope journal 
format

• The system has not received any journaled messages from your server for 
the last 24 hours
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Appendix A
Journaling Setup Checklist Appendix A
Use the following checklist to verify that you have successfully completed all the 
steps necessary to set up journaling on your Exchange Server.

Install the Postini templates

Postini provides two database templates that allow the Domino 
server to work with Postini Message Archiving:

• Postini Mail Journaling template (postinimailjrn.ntf)

• Postini Log template (postinilog.ntf)

For more information, see “Step 1. Install the Postini Templates” 
on page 18.

Create the Mail Journaling Database

After you install the Postini templates, you need to create the Mail 
Journaling database. Your Domino Mail Router will send a copy 
of each journaled email message to this database. You need to 
create the database on the server to which you are sending your 
journaled email.

For more information, see “Step 2: Create the Mail Journaling 
Database” on page 19.

Configure Access Control for the Mail Journaling Database

The Access Control List (ACL) for a database controls which 
users can perform which tasks in the database, and which 
servers can replicate which data in the database.

For more information, see “Step 3: Configure Access Control for 
the Mail Journaling Database” on page 21
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Set Properties for the Mail Journaling Database

You need to open the Database properties dialog box, and set 
properties on the Basics, Design, Launch, Full Text, and 
Advanced tabs.

For more information, see “Step 4: Set Properties for the Mail 
Journaling Database” on page 24.

Create the Mail-in Database Document

After you create and configure the Mail Journaling database 
(Domino Mail Journal), you then have to create the 
corresponding Mail-In Database document so that the database 
can receive mail.

For more information, see “Step 5: Create the Mail-in Database 
Document” on page 26.

Configure the Domino Server for Journaling

Journaling is enabled from the Configuration Settings document. 
You can modify an existing document, or create a new one.

For more information, see “Step 6: Configure the Domino Server 
for Journaling” on page 27.

(Optional) Create Postini Log Database

If you want to log the activity of the Postini Journaling Agent, you 
need to create the Postini Log database.

For more information, see “Step 7: (Optional) Create Postini Log 
Database” on page 29.

Configure the Postini Journaling Agent

Configuration of the agent involves:

• Setting properties in the profile document

• Setting the heap size for the JVM

For more information, see “Step 8: Configure the Postini 
Journaling Agent” on page 30.

Activate Journaling

Restart the router on the Domino server in order to activate 
journaling.

For more information, see “Step 9: Activate Journaling” on 
page 32.
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Verify Domino Server Journaling Setup

After you finish setting up Domino Server journaling, you can 
verify that messages are being journaled and archived as 
expected:

• Verify journaling

• Verify archiving

For more information, see “Verify Domino Server Journaling 
Setup” on page 33.
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